安装PHP(gd)扩展时出错

时间:2007-09-14 00:04:43   来源:chinaunix  作者:  点击:次  出处:技术无忧
关键字:gd php X11

 usr/X11R6 exists, but it is not a symlink. Installation cannot proceed.
This looks like an incompletely removed old version of X.  In the current version, /usr/X11R6 must be a symlink if it exists at all.Please read /usr/ports/UPDATING (entry of 20070519) for the procedure to upgrade X.org related ports.*** Error code 1

===> Verifying install for /usr/local/libdata/xorg/libraries in /usr/ports/x11/xorg-libraries
/usr/X11R6 exists, but it is not a symlink. Installation cannot proceed.
This looks like an incompletely removed old version of X. In the current version, /usr/X11R6 must be a symlink if it exists at all.Please read /usr/ports/UPDATING (entry of 20070519) for the procedure to upgrade X.org related ports.*** Error code 1

Stop in /usr/ports/x11/xorg-libraries.
*** Error code 1

Stop in /usr/ports/graphics/php4-gd.
*** Error code 1

Stop in /usr/ports/lang/php4-extensions.
*** Error code 1

Stop in /usr/ports/lang/php4-extensions.
   

/usr/X11R6 exists, but it is not a symlink
已经写清楚了,安装程序发现该目录不是一个符号链接,所以他不继续下去。
你的xorg的版本是多少,最新的php-extension要求xorg7.2,安装程序认为你的xorg不完整。
要不然选择正常升级到xorg7.2,要不然选择在编译的时候不编译x11相关的东西,关于这个问题前面实在有很多帖子,查一查吧

解决办法为:rm -R-f  /usr/X11R6 ,然后继续ports安装即可

或者(站长推荐):

make WITHOUT_X11=yes install

拥有帝国一切,皆有可能。欢迎访问phome.net

相关文章

文章评论

共有 0 位网友发表了评论 此处只显示部分留言 点击查看完整评论页面